Yes, I'm aware there are other threads about this same topic, but all seem a bit dated, so I mostly would like to share my frustration with my experience and document it, should someone from Inuslet/Abbott ever care to make their software work for those of us who refuse to either a) use a dedicated Windows machine or b) BootCamp into Windows.

I'm a new OmniPod user and was very hopeful that I would be able to export the data from my PDM to the CoPilot software by using a Windows VM on my Mac. I had read the other posts (1)(2)(3)(4) about people's experiences, but thought I would somehow have better luck. I was wrong.

I have both the Abbott CoPilot software and the OmniPod extension installed on a copy of Windows 7 running as a virtual machine via VMWare Fusion 4 on my MacBook Pro, which is running OS X 10.7 (not that any of that matters). When I plug in the PDM, it gives me the USB device detected and that it is preparing data. It then says, "USB device ready". At this point you would think it is ready to communicate with the CoPilot software. Unfortunately, Windows gives me a "USB Device Not Recognized" message in the task bar.

When I click the bubble I'm presented with the USB devices list and in bold is what Windows describes as an "Unknown Device".

Now granted, I'm not a Windows user, but typically I would think that means it needs a driver of some kind. As far as I can tell from what I've found on the Googles, no such driver exists.

Feeling adventurous I decided to try and go through the motions in CoPilot to see if the PDM would still export/upload the data. I click on the "DataEntry" menu item and select "Read OmniPod PDM". I'm then greeted with a delightful message that says, "Make sure PDM is connected and says "Ready" and click "Retry" to continue or "Cancel" to return to CoPilot".

When I click the Retrybutton I get another warm and happy error message. This one says, "An unexpected error occurred while reading data from the OmniPod PDM. Please attempt to read data from the OmniPod PDM again, or call Customer Care for assistance (code 2). Cannot read data from device".

I click the OK button on that message and get a more generic Windows error message saying, "An error occurred while reading data".

Thanks, I wasn't clear that something was wrong there CoPilot software.

 

That's as far as I've gotten, which isn't very far at all. I've also tried doing the OmniPod PDM Settings Report option under the OmniPod menu, but I get much of the same. No PDM detected. Sad. I am ok with the fact that they don't have Mac software, but I'm trying really hard here to make it work in this VM. I guess there's some kind of disconnect with the PDM as a USB device and the way VMWare Fusion handles it. I can get just about every other USB device I've tried in the past to connect without issue to a Windows VM, so this one is a special case of annoying.

 

If anyone has had any luck with getting their PDM to communicate with Windows as a VM on their Mac, please let me know your secrets.

EDIT: I finally gave in an tried using an actual Windows computer. My father had an ancient Toshiba notebook lying around and I threw a fresh copy of XP on it and installed CoPilot and the OmniPod extension and downloaded my data. I noticed the PDM showed up as a USB storage device on the computer. That makes me think you don't need a driver for it and all the CoPilot software is doing is taking the .ibf file on the PDM and copying and interpereting it to a human readable format. Either way, it does work, but my MacBook Pro is sad and wants OmniPod to write a new web based system for downloading PDM data.

Tags: copilot, export, mac, omnipod, parallels, pdm, software, upload, vm, vmware fusion, More…windows

Views: 1326

Replies to This Discussion

Did you try Omni tech support? If anyone would know, seems like they would. I use a Mac but always have to pull out the Dell when I need to get data off my PDM. Good luck. If you figure it out, please update this thread.

I haven't contacted OmniPod support. I just assumed they would give me the OmniPod and CoPilot are not intended to work with a Mac. I guess I could leave out the part that I'm trying to do it via a VM ;)

It's an interesting question. I would like to know the answer and why it's not possible if that's their answer. I've been thinking of getting bootcamp. I run a maclab at school and it might be useful to have the option of running Windows.

Yeah, ultimately if I want to get the data, I'll likely either BootCamp my Mac or use my wife's Windows computer. I just am morally opposed to that idea, and even using a Windows VM makes me hurt a little inside.

I think it's worth calling them - even if they can't help you - to at least make them more aware of the number of people who use both Omnipod and a Mac. I wish they would take a survey of Omnipod users and what systems they use. I would bet a large percentage of people who use Omnipod use a Mac.

Yeah, there are a lot of people who uses Macs these days in general. And with Medtronic announcing Mac compatibility with their CareLink adapter last year (link) and the new t:slim pump by Tandem Diabetes Care announcing their pump will be Windows/Mac compatible via a web app called t:connect (link). Insulet/OmniPod needs to get on the bandwagon. I would LOVE LOVE LOVE a web app that had to just use some kind of plugin to connect to the PDM. That would be amazing.

Have you tried an older version of Windows, such as XP, by any chance? With a Windows environment, once a device shows up as "unknown", Windows won't work with it. While the PDM is still plugged in, try removing the unknown device from Device Manager and have Windows scan for new hardware again.

You know, I considered the fact that Windows 7 isn't an explicitly supported OS version on the system requirements list on the software page (link), but I just assumed it would work. Unfortunately I don't have a copy of Windows XP to install as a VM. I guess I could uh acquire one from the Internet, but I generally try to avoid that sort of thing.

Actually, my CoPilot system does work on my Windows 7, but I thought it wouldn't hurt to try an older version. Did you try the Device Manager suggestion? I've had that work for old dial up modems before. At first, Windows treats it as unknown. But after removing it from Device Manager and having it scan again, it seems to recognize it then. Weird, but that's Windows.....

I did try both disable and uninstall from device manager. When I uninstall and scan for hardware changes it finds it again and tries to "install" the driver software. I then just get this message:

Sounds like Kristen might have your answer. Good luck, hope you get it figured out.

I am a Windows user but was getting the exact same error messages that you are. I finally ended up talking with someone at Insulet. He had me pull up my list of programs and asked how many I had for Omnipod. Long story short, when I downloaded the second step from the omnipod website, the driver did not install. We aren't sure why but he has me uninstall the other omnipod program in there and then reinstall everything through the website. Then we checked to be sure the driver did get installed and it was there. Everything has worked fine since.

In your programs, the driver is listed as: OmniPod Extension/PSR
The other file is called: OmniPod Extension for CoPilot

They had me try many other things before we found this problem, but since it only happened a few days ago, I am willing to bet that you are having the same problem. Let me know! :)

RSS

Advertisement



REsources

From the Diabetes Hands Foundation blog...

#MedicareCoverCGM Panel Discussion

If you follow the diabetes online community, you know that #MedicareCoverCGM is a big deal. We have continued to raise awareness on #MedicareCoverCGM because we believe that ALL people living with diabetes should have access to continuous glucose monitors (CGM). With Read on! →

#WalkWithD: Making MORE Sense of Diabetes

  A few years ago, we at Diabetes Hands Foundation reached out to the members on TuDiabetes and asked them to share their perspective of life with diabetes through one of the five senses, as part of an initiative called Read on! →

Diabetes Hands Foundation Team

DHF TEAM

Manny Hernandez
(Co-Founder, Editor, has LADA)

Emily Coles
(Head of Communities, has type 1)

Mila Ferrer
(EsTuDiabetes Community Manager, mother of a child with type 1)

Mike Lawson
(Head of Experience, has type 1)

Corinna Cornejo
(Development Manager, has type 2)

Desiree Johnson  (Administrative and Programs Assistant, has type 1)


DHF VOLUNTEERS


Lead Administrator

Bradford (has type 1)


Administrators

Lorraine (mother of type 1)
Marie B (has type 1)

Brian (bsc) (has type 2)

Gary (has type 2)

David (dns) (type 2)

 

LIKE us on Facebook

Spread the word

Loading…

This website is certified by Health On the Net Foundation. Click to verify. This site complies with the HONcode standard for trustworthy health information: verify here.

© 2014   A community of people touched by diabetes, run by the Diabetes Hands Foundation.

Badges  |  Contact Us  |  Terms of Service