Yes, I'm aware there are other threads about this same topic, but all seem a bit dated, so I mostly would like to share my frustration with my experience and document it, should someone from Inuslet/Abbott ever care to make their software work for those of us who refuse to either a) use a dedicated Windows machine or b) BootCamp into Windows.

I'm a new OmniPod user and was very hopeful that I would be able to export the data from my PDM to the CoPilot software by using a Windows VM on my Mac. I had read the other posts (1)(2)(3)(4) about people's experiences, but thought I would somehow have better luck. I was wrong.

I have both the Abbott CoPilot software and the OmniPod extension installed on a copy of Windows 7 running as a virtual machine via VMWare Fusion 4 on my MacBook Pro, which is running OS X 10.7 (not that any of that matters). When I plug in the PDM, it gives me the USB device detected and that it is preparing data. It then says, "USB device ready". At this point you would think it is ready to communicate with the CoPilot software. Unfortunately, Windows gives me a "USB Device Not Recognized" message in the task bar.

When I click the bubble I'm presented with the USB devices list and in bold is what Windows describes as an "Unknown Device".

Now granted, I'm not a Windows user, but typically I would think that means it needs a driver of some kind. As far as I can tell from what I've found on the Googles, no such driver exists.

Feeling adventurous I decided to try and go through the motions in CoPilot to see if the PDM would still export/upload the data. I click on the "DataEntry" menu item and select "Read OmniPod PDM". I'm then greeted with a delightful message that says, "Make sure PDM is connected and says "Ready" and click "Retry" to continue or "Cancel" to return to CoPilot".

When I click the Retrybutton I get another warm and happy error message. This one says, "An unexpected error occurred while reading data from the OmniPod PDM. Please attempt to read data from the OmniPod PDM again, or call Customer Care for assistance (code 2). Cannot read data from device".

I click the OK button on that message and get a more generic Windows error message saying, "An error occurred while reading data".

Thanks, I wasn't clear that something was wrong there CoPilot software.

 

That's as far as I've gotten, which isn't very far at all. I've also tried doing the OmniPod PDM Settings Report option under the OmniPod menu, but I get much of the same. No PDM detected. Sad. I am ok with the fact that they don't have Mac software, but I'm trying really hard here to make it work in this VM. I guess there's some kind of disconnect with the PDM as a USB device and the way VMWare Fusion handles it. I can get just about every other USB device I've tried in the past to connect without issue to a Windows VM, so this one is a special case of annoying.

 

If anyone has had any luck with getting their PDM to communicate with Windows as a VM on their Mac, please let me know your secrets.

EDIT: I finally gave in an tried using an actual Windows computer. My father had an ancient Toshiba notebook lying around and I threw a fresh copy of XP on it and installed CoPilot and the OmniPod extension and downloaded my data. I noticed the PDM showed up as a USB storage device on the computer. That makes me think you don't need a driver for it and all the CoPilot software is doing is taking the .ibf file on the PDM and copying and interpereting it to a human readable format. Either way, it does work, but my MacBook Pro is sad and wants OmniPod to write a new web based system for downloading PDM data.

Tags: copilot, export, mac, omnipod, parallels, pdm, software, upload, vm, vmware fusion, More…windows

Views: 1169

Replies to This Discussion

EDIT: Ah, I think I found what you meant. I went to Uninstall a Program and found the two things you talked about.

Hmm, not sure I follow exactly what you're talking about. When you say in your programs, do you mean Start Menu (Windows Icon) - All Programs? Because all I see there is CoPilot Health Management System folder and application with the same name inside. I also have an OmniPod folder that has a PDF and OmniPod PDM Settings Report application.

If you meant C:\Program Files I do have the same CoPilot Health Management System folder with a bunch of stuff inside. Inside the Plugins folder I have a OmniPod.AG file that does who knows what. Also in Program Files is an OmniPod folder that has a bunch of files inside.

Perhaps I just need to get on the phone with Insulet. I actually called today and was told the person who specialized in CoPilot was busy and they said they'd call me back today. Well that hasn't happened yet, but maybe I'll try again tomorrow. Thanks for your help though. I'll perhaps reference some of your troubles when I talk to support.

I'm sorry for not being clear! I did mean in your uninstall a program (under the control panel) area. When I went into mine the first time the OmniPod Extension/PSR was not installed so that was my problem. It looks like you have everything you need there though.

The person you are referencing at Insulet should get back to you. I was told the same thing when I called and he got back to me a few hours later. He was very nice and worked with me to figure it out. I am not sure that I would tell him right away that you are trying to run it on a Mac though. Not sure that he will help you further, but you never know! He did have me try plugging in another device with the cord that came with my OmniPod to make sure that it wasn't the cord (our GPS uses the same size USB). There were also several things that he had me try within the CoPilot program itself. Hopefully they can get it all worked out for you!

Thanks, well they didn't ever call me back today. I'll try again tomorrow maybe. Hopefully I can get it working. Thanks again for all your help :D

You've got exactly the same intermittent problems I see with the Omnipod, but I'm running on a pure Intel Windows 7.

There are major bugs in the Omnipod interface; probably both the PDM and the CoPilot extension. I think it's trying to do more than be a simple USB storage device, probably so that CoPilot can download the settings, but it's basically broken. The fact that Windows gave you "USB device not recognized" (I've not seen that part of the mis-dialogue before) is interesting. 99% of what the PDM does seems to be to write a large file of all the data so that CoPilot can read it, but "USB device not recognized" means that there is a bug in the Omnipod.

We're not going to see the end of this until Insulet give us all new PDMs; there's no option to download new software for the PDM. My personal experience is that if I keep trying it eventually "works", but it's broken.

You could ask for your money back.

John Bowler jbowler @ acm.org

Wow, that doesn't make me very excited about ever getting it to work. Either as a Windows VM or on an actual Windows machine. Pretty disappointing. Especially with other pump manufacturers working to increase compatibility with other OSes besides Windows. I hope that the new PDMs (I've heard here on tudiabetes and from my OmniPod rep) that are coming will come with some new software that is Mac & Windows or web based. That would be ideal. Here's to hoping.

I have a MacBookPro that I also installed Windows on a small partition of the hard drive. I'm not following you on all the tech stuff, but just wanted you to know that it works on mine. I just boot to the windows partition and everything thing works fine with CoPilot. I do my Dexcom on there too. I did have an issue when I installed the Parallels software that allows you to work on both operating systems without rebooting. The CoPilot crashed and wiped out the pdm data. I had to re enter it all. So now I just reboot to windows without using Parallels.

RSS

Advertisement



REsources

From the Diabetes Hands Foundation blog...

FDA Docket Extended! We Need You.

If you are new to diabetes advocacy in the traditional sense of the word, you may be thinking, “What the heck is a docket!?” I certainly was the first twenty times I heard it (yes it took that long). For Read on! →

An Open Letter from @AskManny, @DiabetesHF to @NYTRosenthal, @NYTimes

Dear Ms. Rosenthal: I am a person living with type 1 diabetes since the age of 30. I am also the President and co-Founder of the Diabetes Hands Foundation, a nonprofit aimed at connecting and mobilizing the diabetes community. Seeing Read on! →

Diabetes Hands Foundation Team

DHF TEAM

Manny Hernandez
(Co-Founder, Editor, has LADA)

Emily Coles
(Head of Communities, has type 1)

Mila Ferrer
(EsTuDiabetes Community Manager, mother of a child with type 1)

Mike Lawson
(Head of Experience, has type 1)

Corinna Cornejo
(Development Manager, has type 2)

Heather Gabel
(Administrative and Programs Assistant, has type 1)

DHF VOLUNTEERS


Lead Administrator
Bradford (has type 1)

Administrators
Lorraine (mother of type 1)
Marie B (has type 1)

Brian (bsc) (has type 2)

Gary (has type 2)

David (dns) (type 2)

 

LIKE us on Facebook

Spread the word

Loading…

This website is certified by Health On the Net Foundation. Click to verify. This site complies with the HONcode standard for trustworthy health information: verify here.

© 2014   A community of people touched by diabetes, run by the Diabetes Hands Foundation.

Badges  |  Contact Us  |  Terms of Service